Project

General

Profile

Actions

Bug #80589

closed

filelist lacks items

Added by Markus Klein almost 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-03-30
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Consider a folder with 42 files.
One of the file is a hidden file like .htaccess the others are numbered from file10 to file50

Since each page in the filelist only shows up to 40 element and hidden files are not shown I would expect to see file50 as single item on the second page.

What actually happens is that the second page shows file49 again and file50 is never shown!

The reason is that LocalDrivers folder traversal logic uses the offset parameter (40 in case of the filelist) to forward the iterator to this starting point. This is wrong, since the iterator storage may contain elements before the offset, that might be filtered away by file filters (like hidden files).

The correct solution is to iterate over the whole storage and decrease the offset whenever a potentially valid file is found.
This way the expected behaviour can be seen.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #78891: fileadmin: list of files off by twoClosed2016-12-05

Actions
Actions #1

Updated by Markus Klein almost 7 years ago

  • TYPO3 Version changed from 7 to 6.2
Actions #2

Updated by Gerrit Code Review almost 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52275

Actions #3

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52287

Actions #4

Updated by Gerrit Code Review almost 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52288

Actions #5

Updated by Markus Klein almost 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF