Bug #80722

'__UNSET' in columnsOverrides not working and TCA migration check missing

Added by Albrecht Köhnlein over 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-04-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I have this code in one of my extensions:

$GLOBALS['TCA']['tt_content']['types']['myextension_plugin'] = array(
    'showitem' => '...',
    'columnsOverrides' => array(
        'imageorient' => array(
            'config' => array(
                'items' => array(
                    1 => '__UNSET',
                    2 => '__UNSET',
                    4 => '__UNSET',
                    5 => '__UNSET',
                    6 => '__UNSET',
                    7 => '__UNSET',
                    8 => '__UNSET',
                    9 => '__UNSET',
                    10 => '__UNSET',
                ),
            ),
        ),
);

When I want to open a content element with this type, I only see this error since the upgrade to TYPO3 8.7:

#1439288036: An item in field imageorient of table tt_content is not an array as expected

I asked in slack about that and was told, the syntax changed and I should use the TCA migration check in install tool. I fixed all messages related to my extension, but the problem is still the same. And none of the messages, I fixed, was about "imageorient", "__UNSET" or "columnsOverride".

So I think, the TCA migration check should be extended, if this is missing.


Related issues

Related to TYPO3 Core - Bug #80321: Use array_replace_recursive to merge columnsOverridesClosed2017-03-17

Actions
#1

Updated by Christian Kuhn over 3 years ago

I'm sorry to say we had to remove the __unset feature at this point. See the related issue for more details. Your only chance is to create either a general 'columns' setup for that field which does not provide the items by default and then add in via columnsOverrides at those places that need it, or to blind the options on pageTsConfig level for this type.

#2

Updated by Christian Kuhn over 3 years ago

  • Status changed from New to Needs Feedback
#3

Updated by Albrecht Köhnlein over 3 years ago

:-(

Sad. But I still think, it should be listed in TCA migration checks!?

#4

Updated by Alexander Opitz over 3 years ago

  • Status changed from Needs Feedback to New
#5

Updated by Christian Kuhn about 2 years ago

  • Status changed from New to Closed

hmmm. there is nothing to migrate. it just stops working. i also think this is really a seldom edge case (it only worked for a short time in v7 if i remember correctly), so i think it's not worth the hassle to proceed on this issue. i hope it's ok with you if i close it for now.

Also available in: Atom PDF