Bug #81045

Textmedia - Elements without Cropping Tool

Added by Andreas Lau Lau over 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-04-27
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

the textmedia-elements in my Typo3 8.7.1 version is missing the cropping tool when adding a media-element.
There is only the title and description field showing.

I tried it without all typoscript-templates of installed extensions, with Fluid Styled Content and/or Bootstrap-package activated.
I also tried overriding the TCA with imageManipulation but that did not work either.

The Typo3 got updated from 6.2 to 7.6 and then 8.4 and when it came out to 8.7.

It would be much appreciated if you could point me in the right direction.


Related issues

Related to TYPO3 Core - Bug #80719: InlineOverrideChildTca migration is incomplete Closed 2017-04-06

Associated revisions

Revision b6c72882 (diff)
Added by Malte Koitka almost 2 years ago

[BUGFIX] TcaMigration should not skip on existing overrideChildTca

If an overideChildTca key is already added by a TYPO3 core
function like ExtensionManagementUtility::getFileFieldTCAConfig()
the TCA migration should not be skipped. Otherwise the config will
be incomplete and result in missing fields.

The migration is changed that old "foreign_types",
"foreign_selector_fieldTcaOverride" and "foreign_record_defaults"
are merged into new "overrideChildTca", but the new settings
are keps (take precedence) if given.

Resolves: #80719
Resolves: #81045
Releases: master, 8.7
Change-Id: Ic8a0338e0a9882b3b1e7abcd3123fbd7aa2b3505
Reviewed-on: https://review.typo3.org/52693
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Reviewed-by: Henning Liebe <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 5b40db8e (diff)
Added by Malte Koitka almost 2 years ago

[BUGFIX] TcaMigration should not skip on existing overrideChildTca

If an overideChildTca key is already added by a TYPO3 core
function like ExtensionManagementUtility::getFileFieldTCAConfig()
the TCA migration should not be skipped. Otherwise the config will
be incomplete and result in missing fields.

The migration is changed that old "foreign_types",
"foreign_selector_fieldTcaOverride" and "foreign_record_defaults"
are merged into new "overrideChildTca", but the new settings
are keps (take precedence) if given.

Resolves: #80719
Resolves: #81045
Releases: master, 8.7
Change-Id: Ic8a0338e0a9882b3b1e7abcd3123fbd7aa2b3505
Reviewed-on: https://review.typo3.org/54582
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Frans Saris over 2 years ago

  • Status changed from New to Needs Feedback

Are the link and alt field also missing? Looks like your TCA is wrongly overritten somewhere. Could you try to disable all additional extensions. And maybe you override TCA self somewhere?

I assume you are looking at this as an admin and not as an editor. Because then it could be a missing permission.

#2 Updated by Malte Koitka over 2 years ago

Sounds like it might be related to #80719. Though an untouched textmedia TCA should not be affected by this.

#3 Updated by Andreas Lau Lau over 2 years ago

Thanks to your tip i found it, it was the bootstrap_package (newest version).

I took out the part about the column "assets" in the tt_content_general_columns.php and them images where could be edited again in the content element.

Though now i need to find a way to keep it that way when updating the bootstrap_package.

Thanks for your time

#4 Updated by Gerrit Code Review over 2 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52693

#5 Updated by Andreas Lau Lau over 2 years ago

Hello,

tried that patch and its working fine, nice work. Thanks.

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52693

#7 Updated by Christian Kuhn almost 2 years ago

  • Related to Bug #80719: InlineOverrideChildTca migration is incomplete added

#8 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52693

#9 Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52693

#10 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54582

#11 Updated by Malte Koitka almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF