Bug #81052

Non-existent field "fe_groups" is used in BackendUtility::ADMCMD_previewCmds()

Added by Andreas Fernandez over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
Start date:
2017-04-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Remote Sprint

Related issues

Related to TYPO3 Core - Task #80317: Deprecate BackendUtility::getRecordRaw Closed 2017-03-17

Associated revisions

Revision 6571e8c8 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Use correct field `fe_group` instead of non-existent `fe_groups`

Since #80317, `BackendUtility::ADMCMD_previewCmds()` uses the field
`fe_groups` for the `pages` table, which does not exist. This patch
fixes the regression by using `fe_group` again.

Resolves: #81052
Related: #80317
Releases: master, 8.7
Change-Id: I08106704589fcab7607a9448b2eae646c611de93
Reviewed-on: https://review.typo3.org/52644
Tested-by: TYPO3com <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 36447587 (diff)
Added by Andreas Fernandez over 2 years ago

[BUGFIX] Use correct field `fe_group` instead of non-existent `fe_groups`

Since #80317, `BackendUtility::ADMCMD_previewCmds()` uses the field
`fe_groups` for the `pages` table, which does not exist. This patch
fixes the regression by using `fe_group` again.

Resolves: #81052
Related: #80317
Releases: master, 8.7
Change-Id: I08106704589fcab7607a9448b2eae646c611de93
Reviewed-on: https://review.typo3.org/52645
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Andreas Fernandez over 2 years ago

  • Related to Task #80317: Deprecate BackendUtility::getRecordRaw added

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52644

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52644

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/52645

#5 Updated by Andreas Fernandez over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF