Bug #81098

TCA inline load wrong version of translated child record in workspaces

Added by Marc Bauer over 4 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-05-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

You have an IRRE field without an MM relation, only comma separate list. If you work in workspaces and you translate the parent record with some child records then you can't edit the translated child record inline the parent record. After saving these child records the changes will saved in Database but changes will not shown in Backend parent inline because there is anything not working with relation handler translations and localization.

TYPO3 7.6.18

#1

Updated by Christian Kuhn about 1 year ago

  • Status changed from New to Needs Feedback

Unable to reproduce in v11 master and v10:

I'm using the 'irre_tutorial' as test extension - linked it from core testing to typo3conf/ext:

irre_tutorial -> ../../typo3/sysext/core/Tests/Functional/Fixtures/Extensions/irre_tutorial/

Then loading extension and db analyzer.

  • Create a page, translate page in live
  • Select a workspace, go to list module
  • Add a record "1:n CSV: Hotels" together with an "Offer" child record.
  • Translate the hotel record to other language using the list module, will localize the offer child, too.
  • Edit the translated hotel record: the translated offer is shown, can be edited and saved.

If there was a bug, i assume it has been fixed somewhere between v7 and v10. If v9 is still affected, we probably won't fix it there anymore.

Marc, could you confirm the issue is solved with younger core versions for you? If it still exists for you, would you like to add a description on how to reproduce your issue?

#2

Updated by Christian Kuhn 11 months ago

  • Status changed from Needs Feedback to Closed

Closing issue. Please open a new one if you think the issue still exists in recent core versions and refer to this issue.

Also available in: Atom PDF