Bug #81104

ckeditor does not converts inch-mark to " entity

Added by Joe Jones over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2017-05-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
ckeditor quotes glyphe inch entities
Complexity:
Is Regression:
Sprint Focus:

Description

Dear TYPO3-Team,

by changing to the new RTE-Editor I found a problem with quotationmarks. The typed " does not encoded to &quod; (see Screenshot). The green one was formated by the old RTE and afterwards quotes where replaced by stdWrap.replacement in „ resp. “. The yellow marks are formated by the ckeditor. It is still an inch-mark.

Please have a look at it. It is quite important for correct typography in the web.

Thank you for your work
Martin


Files

missing_quot.PNG (18.5 KB) missing_quot.PNG Joe Jones, 2017-05-02 12:13
#1

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from New to Needs Feedback

Hi and sorry for the late answer; I suggest you to add the CKEditor "autocorrect" add-on that adds exactly the feature you asked for, out of the box (plus some more :) )

Refences:

https://github.com/danyaPostfactum/ckeditor-autocorrect-plugin

https://typo3worx.eu/2017/05/extend-typo3-ckeditor/

Could you tell us if it is sufficient for you? Thank you!

#2

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (next-patchlevel)

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or that there is still work that should be done on this topic, please reopen it or open a new issue with a reference to this one. Thank you.

Thank you and best regards

Also available in: Atom PDF