Bug #81502

TCA: Icons below select fields are always shown

Added by Dirk Wenzel over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-06-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Expected Behaviour

I expect that no icon is shown below a select field of render type selectSingle by default or when the field is configured in TCA as follows

$GLOBALS['TCA'][<table name>]['columns'][<field name>]['config']['fieldWizard'] = [
    'selectIcons' => [
        'disabled' => true,
    ],
];

Observed Behaviour

For each entry in the select list an icon is shown. When no icons are configured for a single entry, the same default icon is repeated for every entry.

Reference

Current documentation states:
"Render thumbnails of icons below the select drop-down. Disabled by default."

see: https://docs.typo3.org/typo3cms/TCAReference/8-dev/ColumnsConfig/Type/Select.html#selecticons

#1

Updated by Dirk Wenzel over 3 years ago

This error only occurs if the obsolete option showIconTable is set. This option is automatically migrated and a setting as described above is ignored.

#2

Updated by Mona Muzaffar about 3 years ago

  • Status changed from New to Closed

see comment above.
since this doesn't seem to be a bug I close this issue.

If you think that this is the wrong decision or experience this issue again, then please reopen this ticket or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF