Bug #81565

ID parameter needs to be passed for the cHash calculation!

Added by Christian Welzel over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
-
Start date:
2017-06-13
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

hi there,

on my system with PHP 7.0.19-he.0 (some version of Hosteurope) i get the above error, while sending a form using the buildin FORM generator/plugin.
The error get triggered, when extbase tries to create the chash in TYPO3\CMS\Extbase\Mvc\Web\CacheHashEnforcer::enforceForRequest().
There is a call to http_build_query($parameters) which on my system returns the string urlencoded:

tx_form_formframework%5Baction%5D=perform&tx_form_formframework%5Bcontroller%5D=FormFrontend&tx_form_formframework%5Bpartneranfrage%5D%5B__state%5D=TzozOToiVFlQTzNcQ01TXEZvcm1cRG9tYWluXFJ1bnRpbWVcRm9ybVN0YXRlIjoyOntzOjI1OiIAKgBsYXN0RGlzcGxheWVkUGFnZUluZGV4IjtpOjA7czoxMzoiACoAZm9ybVZhbHVlcyI7YTowOnt9fQ%3D%3D93e7750726cd378fb6b8dfabb8327a8464b45f73&tx_form_formframework%5Bpartneranfrage%5D%5Btextarea-1%5D=frane&tx_form_formframework%5Bpartneranfrage%5D%5Btext-2%5D=mame&tx_form_formframework%5Bpartneranfrage%5D%5Btext-3%5D=&tx_form_formframework%5Bpartneranfrage%5D%5Btext-4%5D=&tx_form_formframework%5Bpartneranfrage%5D%5Btext-5%5D=&tx_form_formframework%5Bpartneranfrage%5D%5Btext-6%5D=&tx_form_formframework%5Bpartneranfrage%5D%5Btext-7%5D=ffo&tx_form_formframework%5Bpartneranfrage%5D%5Btext-8%5D=&tx_form_formframework%5Bpartneranfrage%5D%5Btext-9%5D=no&tx_form_formframework%5Bpartneranfrage%5D%5BfZjpSUxFImVOHyr8BMDwlRWvJT%5D=&tx_form_formframework%5Bpartneranfrage%5D%5B__currentPage%5D=1&id=8

which results in the following array in CacheHashCalculator::getRelevantParameters():

Array
(
[tx_form_formframework[action]] => perform
[amp;tx_form_formframework[controller]] => FormFrontend
[amp;tx_form_formframework[partneranfrage][__state]] => TzozOToiVFlQTzNcQ01TXEZvcm1cRG9tYWluXFJ1bnRpbWVcRm9ybVN0YXRlIjoyOntzOjI1OiIAKgBsYXN0RGlzcGxheWVkUGFnZUluZGV4IjtpOjA7czoxMzoiACoAZm9ybVZhbHVlcyI7YTowOnt9fQ==93e7750726cd378fb6b8dfabb8327a8464b45f73
[amp;tx_form_formframework[partneranfrage][textarea-1]] => frane
[amp;tx_form_formframework[partneranfrage][text-2]] => mame
[amp;tx_form_formframework[partneranfrage][text-3]] =>
[amp;tx_form_formframework[partneranfrage][text-4]] =>
[amp;tx_form_formframework[partneranfrage][text-5]] =>
[amp;tx_form_formframework[partneranfrage][text-6]] =>
[amp;tx_form_formframework[partneranfrage][text-7]] => ffo
[amp;tx_form_formframework[partneranfrage][text-8]] =>
[amp;tx_form_formframework[partneranfrage][text-9]] => no
[amp;tx_form_formframework[partneranfrage][fZjpSUxFImVOHyr8BMDwlRWvJT]] =>
[amp;tx_form_formframework[partneranfrage][__currentPage]] => 1
[amp;id] => 8
)

I'm not sure, why this happens, but a change from http_build_query($parameters) to http_build_query($parameters, '', '&') fixes the problem.


Related issues

Duplicates TYPO3 Core - Bug #81293: cacheHash fails to be generated because of missing id although id is present in request-string Closed 2017-05-22

History

#1 Updated by Markus Klein over 2 years ago

  • Status changed from New to Closed

Duplicate of #81293

#2 Updated by Markus Klein over 2 years ago

  • Duplicates Bug #81293: cacheHash fails to be generated because of missing id although id is present in request-string added

Also available in: Atom PDF