Bug #81599

Error Message on not determined TYPO3_PATH_WEB produces an error on itself.

Added by Anja Leichsenring about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Should have
Category:
-
Target version:
-
Start date:
2017-06-17
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

'Unable to determine path to entry script. Please check your path or set an environment variable \'TYPO3_PATH_WEB\' to your root path.' will also output error messages about a not defined constant named LF.

This constant is used for the output, but not defined due to the not determined entry point.

Associated revisions

Revision 1d98daf1 (diff)
Added by Anja Leichsenring about 1 year ago

[BUGFIX] Remove possibly undefined constant from test bootstraps

The constant LF might not be defined in functional and unit test
bootstrap by the time the script terminates with an error message.

Replacing the usage of this constant with the native value for a
linebreak causes the same result for the error message, but prevents
the additional and confusing messages about the not existing constant.

Change-Id: I66bd2092875e33fa8bb93a2a57c54daeaeb15ecf
Resolves: #81599
Releases: 7.6
Reviewed-on: https://review.typo3.org/53239
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53239

#2 Updated by Anja Leichsenring about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF