Bug #81610

Install Tool > Database Analyzer: Migration failed for fields containing a space

Added by Frank Naegler almost 5 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
Database API (Doctrine DBAL)
Target version:
Start date:
2017-06-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In one of my installations, the install tool database analyzer shows the following query to execute:

ALTER TABLE tx_foo_bar CHANGE l18n_diffsourc e `zzz_deleted_l18n_diffsourc e` MEDIUMBLOB DEFAULT NULL

The existing field contains really a space, which is fine for some databases. (sure in is this case it is a mistake)

After executing the query, this query fails:

Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '`zzz_deleted_l18n_diffsourc e` MEDIUMBLOB DEFAULT NULL' at line 1

I guess the problem is, that the field name is not quoted.


Files

Screen Shot 2017-07-01 at 10.56.39.png (239 KB) Screen Shot 2017-07-01 at 10.56.39.png Screenshot showing the resulting quoting/migration statements based on this patch Morton Jonuschat, 2017-07-01 20:02
#1

Updated by Morton Jonuschat almost 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Morton Jonuschat
#2

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53373

#4

Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53373

#5

Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53403

#6

Updated by Morton Jonuschat almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF