Project

General

Profile

Actions

Bug #81677

closed

TYPO3 Exception "Section "main" does not exist." under TYPO3 8.7.2

Added by Alexander Grein over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2017-06-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Since updating TYPO3 from 8.7.1 to 8.7.2 I get the TYPO3 Exception "Section "main" does not exist" in the TYPO3 Backend filelist module.


Files


Related issues 1 (0 open1 closed)

Follows TYPO3 Core - Bug #81340: TemplatePaths::fillDefaultsByPackageName does not sort paths correctlyClosed2017-05-24

Actions
Actions #1

Updated by Alexander Grein over 6 years ago

  • Subject changed from TYPO3 Exception Section "main" does not exist. under TYPO3 8.7.2 to TYPO3 Exception "Section "main" does not exist." under TYPO3 8.7.2
Actions #2

Updated by Alexander Grein over 6 years ago

The problem exists under current master und Version 2.2.2 of extension file_list.
Maybe a problem with der extension key in combination with the newest TYPO3 Version?

Actions #3

Updated by Xavier Perseguers over 6 years ago

But the "filelist" module has nothing to do with that extension?

Actions #4

Updated by Alexander Grein over 6 years ago

I don't know, but if I deinstall your extension "file_list" the TYPO3 backend module filelist is works again.

Maybe one of this two commits of the new core version?:
3e59b1400a [BUGFIX] Fix getTemplatePathAndFilename on StandaloneView
c9d6c46e9c [TASK] Set Fluid cache backend to SimpleFileBackend

[EDIT 1]
"Set Fluid cache backend to SimpleFileBackend" seems not to be the reason. I temporary changed the backend back to FileBackend (standard at TYPO3 8.7.1), without any changes of the problem.

[EDIT 2]
The Problem may only exists if you try to overwrite the fluid template paths by changing typoscript constants of your extension like I do:
E.g.:

plugin.tx_filelist {

    view {
        templateRootPath = EXT:interconnection/Resources/Private/Extensions/FileList/Templates/
        partialRootPath = EXT:interconnection/Resources/Private/Extensions/FileList/Partials/
        layoutRootPath = EXT:interconnection/Resources/Private/Extensions/FileList/Layouts/
    }

    settings {
        # cat=plugin.tx_filelist; type=string; label=Format for dates
        dateFormat = d.m.Y H:i

        # cat=plugin.tx_filelist/file; type=string; label=Path to file icons
        fileIconRootPath = EXT:file_list/Resources/Public/Icons/Files/
    }

}

Actions #5

Updated by Alexander Grein over 6 years ago

In a debug session of the backend module filelist, I found this path values, which are definitely wrong.

Actions #6

Updated by Alexander Grein over 6 years ago

As a workaround, adding this to typoscript setup solve the problem:

module.tx_filelist {
    view {
        templateRootPaths.1 >
        templateRootPaths.2 >
        partialRootPaths.1 >
        partialRootPaths.2 >
        layoutRootPaths.1 >
        layoutRootPaths.2 >
    }
}

I think there is a

module.tx_filelist < plugin.tx_filelist

some where in the new core version, which is executed at a different time than before.

I think using an extension key with the same name as a core extension, just with one or more "_" between is always a bad idea.
There ist no way to configure them independently using typoscript, because of
plugin.tx_thisisalwaylowercasewithoutanyslashes ...

Actions #7

Updated by Xavier Perseguers over 6 years ago

Culprit is this commit:

87e688ad6e58ee5768ee0c42aef4a16f113f1f92 is the first bad commit
commit 87e688ad6e58ee5768ee0c42aef4a16f113f1f92
Author: Claus Due <claus@namelesscoder.net>
Date:   Wed May 24 17:41:14 2017 +0200

    [BUGFIX] Make TemplatePaths->fillDefaultsByPackageName sort paths

    Due to the sequence of methods being called from this method,
    it is necessary to sort TS-configured paths right when they are
    resolved instead of passing the unsorted array further down.

    Patch also sorts methods protected below public; true diff is
    one line. Toggle this line between before/after and run the test
    to see the problem demonstrated.

    See issue description for a more detailed reasoning.

    Change-Id: I0317c4ee683c2fac2c7def7c6d79f947afc4b078
    Resolves: #81340
    Releases: master, 8.7
    Reviewed-on: https://review.typo3.org/53112
    Tested-by: TYPO3com <no-reply@typo3.com>
    Reviewed-by: Christian Kuhn <lolli@schwarzbu.ch>
    Tested-by: Christian Kuhn <lolli@schwarzbu.ch>

:040000 040000 996c991ed686d302bd571c0a5680a2182ced1c21 1eb6d252f7acd2f589a813d981a196a5cf67ed55 M    typo3
Actions #8

Updated by Xavier Perseguers over 6 years ago

  • Due date set to 2017-05-25
  • Start date changed from 2017-06-22 to 2017-05-25
  • Follows Bug #81340: TemplatePaths::fillDefaultsByPackageName does not sort paths correctly added
Actions #9

Updated by Xavier Perseguers over 6 years ago

  • Project changed from 171 to TYPO3 Core
  • Due date deleted (2017-05-25)
  • Status changed from New to Accepted
  • Target version set to next-patchlevel
  • Start date changed from 2017-05-25 to 2017-06-22
  • TYPO3 Version set to 8
  • Is Regression set to Yes
Actions #10

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53309

Actions #11

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53309

Actions #12

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53309

Actions #13

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53309

Actions #14

Updated by Gerrit Code Review over 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53309

Actions #15

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53314

Actions #16

Updated by Xavier Perseguers over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #17

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF