Bug #81845

SQL Error in "Filelist" search using TYPO3 7 LTS and PostgreSQL

Added by Marco Grahl over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2017-07-12
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
postgresql
Complexity:
Is Regression:
Sprint Focus:

Description

I get the following error after searching in "Filelist" in backend:

ADOdb could not run this query: SELECT "uid", "pid", "missing", "type", "storage", "identifier", "identifier_hash", "extension", "mime_type", "name", "sha1", "size", "creation_date", "modification_date", "folder_hash" FROM "sys_file" WHERE "folder_hash" IN ('ea02c4ccc1470fc0b3c63b26269de13c0f94b803','f71217948c782c1298290d55d5ab1a30e5a9b32a','229b36a1ea65dd9805b9f81d22526490d1ea80fc','3c1f843e316fb733147a3307ecef53b48314a5fb','52af1eeff3de9e794ccce7cb52103aab4d6031a8','5337c7eb4fd4b1f8bb85a74c25c48cfa9e8a641e','303cf112cc56ce2ea203edbfed4d5a6f81cc4d6c','b53351b20fbac92e4a43328ecd9f48790c83bdfb','82bf211c02a15a66a4b6c1fa2c4bf9de0bf06f39','97c6e10fa9c9f70f95a7bd8babcd5241707edb09','f614068b42c7dd264ed8d6a2596c3bc9a1966ec0','f108940a1aa1dda165874209d397d1ecf2661e51','4b778dec76d728b839d62e9103fa0f0f8325ab44','add23e012f9c712f432bc908669d6cc35bf30658','a0b0e384011fa59ee9fa52615219ebe9de1621db','9245977281d634a44e9ffd5613b73597e9086bc5','f774289cd86471a04d05e4169c0ca10f4bd7bda8','85765f0e485d2fbea68f1443df0f40fd6f62a149','5a966cdc41869a9219244546a07901b1b02230fa','5665fc5cf219b373d06ef82e32feecfb4260bbe6','32eded6170f186478324dc1a5e721947eb9bb11c','8bd69d942a3a6e05644eb15b4f574582b1bf3558','8e26c2e323f22db45f0717c6d15ef21cf95e161a','4116f667a47b7a1ba5e59db9377e04cd3cc3046c','fb928707cb57cd1dedc7a2cc0fb16f869f39df8c','347b04667447c0cba8eb737bdac414e35d88bd0a','85b5fa611635351cd769a68c137af5cad6a58d34','38e9cb6405317192409ff5fbd1acbf586ec9aff9','bdb411003742eecb97846acdf3716306dd01b2c2','939f3171f85d7183f47b16780b397361c1eda5fc','a81d0e8a197f2b3b17f300a6272c1a5aca4e13ca','3e9817053ab3b85100af4ed6db67aef249cf55e6','b3fe96af62074411faf1bfa6a62a18b23e338fc8','d90c40f90a79a2aa641433d9d0b1b54b90407aae','f2e5c845ed8233e31b6b769418eceb2fae1bd0bc','26ab0030dc8688afe9d846bf6117a47c54f930a5','072e5b401bc270771624997146fb570713b951c4','2e8e4d368761399dd41bd63e5f8150ff82bcc625','2f8637fc625c524671ca54f80032410f67006ac1','b02e0de6489d03b98417c66063abbac6bf388385','092fdf5b3b2b3685d79affff449e688c19f03a29','1e4b1480ff22f818581b119caf55991915c3b234','29cf20bfb9619c0c5f55d028c4d4dae8a6945f47','b0934a588077f1655094156bbdc795bfa4e329d8','36e5b5fe62b8632bf2ef563eb51ec23a0ecb8673','dce12f4f7ec353851bd40a5d0e7c424736296ab8','1e13c440923618a0c9076261f93d9873c263714a','8de329607ceeadcc334d83e24add3a58f4e8877a','ff42fd5a995e150a0472dac015d9721b9cdd733c','1f0bd2b05db4b8a8e14413e701740b8c8ef3a41f','f64e0f05641cfe6f98599040c48dbfbfe48d3f1a','e51faa7d7170c683395f99e78752138ad7608172','234607e7011dca295a099907cafa45299e0c68b6','6c23a702029bb184c7d0e937c4b2d2468efed795','00dba9dd84e5b88403c89bf58785d1df4eeccb29','b0ec1af3f9577dbab29e99005f26dee0617cc672','1f3f8c943c0a02129f74f84d60764301a832fbbd','c866f59f1bcbed3045a5cb74a74b3dc04c8d4a85','b4d23304c410167d8bd1d25ed974704a9c7871ee','288b623ae44fc562063538398772c10f2bcc9e9f','8770f5588027bbc99d0d897ebcbf42f78257a9e5','54d7156de9aa3a554680dc46b00b3c45cc1555d2','193a4206b7e00ba7808487c310ec5704d0f559c8','cab725d36d553b7e962765fe9743859546030b54','12641bfbe0d04554be20eeafd0e71b2bfc88d07d','d5d8736cb363c2022b1241b44ad071451d7c3ff9','a531d0d1db224618ac2c227c4dea3ecb5c0db30c','13c30a1bfca9afffebcb40aa1192b79b4dff6e33','05812bb8bfc0e89f8965803fd024c241f257d979','b6f2fad146a556373053e94b355a9c1746341bf2','c821d1a4f6b43762cf0f901bf3fe11b31093fde5','17bced5b7fd27a4a4563519fd4f41cb32434a0f2','7dffc902573e252b22539c32f115ff98c56054d7','dd4a5a517dfd83561cb64b590673c9cbdf05220b','6ae32d9005511faf46bd5e49bd18ff7bb3c1ba53','104b7db08b05f17e5c5be24b34ca35ffda7f13f1','344bf5eccdec72c17fa63bf9b4355bd1dfa1917a','7f876bd29fc254fd8acf26132caae6bacf1529e2','7edab1c07638b1ccd5a768dc4d0373c0f73612d8','2fdef30123a6d247c68c8b17b391df040153cc81','8fb14e479531e17dafab1f29dbc35728c118795a','0795cf796b4fc959be0ec00b183c0f47609dd9a5','f958e1a08f572a60e77faaca00b58ed8d13d4976','5e9ee2db0e5f166794a0d2b90d5de60f818d3f09','ccf13c9dac508104a50f29ab04437e5ff39f6410','b6c5e1e8d45dbe68533572934eae76bddb48d742','bc96497fae33eb26f63b9d8b76e4e2b792a1d7ef','19669f1e02c2f16705ec7587044c66443be70725','4e0743c93934dd9a02564d8e654d714bd2dc3d20','0258f8a5f703dd44c350fbfcddeecb1634d46ad4','42099b4af021e53fd8fd4e056c2568d7c2e3ffa8') AND "storage" IN (1) AND "name" ILIKE "%Beschluss%" AND "missing" = 0

After tracing it a bit, the incorrect query seems to be built by escaping the searchword:

ILIKE "%Beschluss%" 

should be
ILIKE '%Beschluss%'

to get the query working!

History

#1 Updated by Georg Ringer over 1 year ago

  • Status changed from New to Closed

please update to 8 which uses doctrine and the query should be fine there. nothing will be done in that regard in 7.

#2 Updated by Dan Untenzu over 1 year ago

Could you please re-open the issue?

I understand that the core team wont put any effort in fixing this bug, since we have Doctrine in version 8 now. But I would like to express refusal that a ticket is closed with the advice to upgrade to some newer TYPO3 version. Version 7 is still a supported LTS version. If by any means somebody experiences the same bug or even has a solution, than this issue may be fixed.

Also available in: Atom PDF