Bug #81950

Resolve disabled sys_workspace.unpublish_time

Added by Oliver Hader over 2 years ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2017-07-24
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The property sys_workspace.unpublish_time was hidden during TYPO3 4.5 development from being displayed with a remark that the feature would not be working (see #12333). However, in version 8.7 and 9-dev the TCA property is still available and still handled in AutoPublishService - however, there's not possibility in the regular backend to define that field.

The workspace auto-publishing process was thought to automatically push a (temporary) version to live at a given time (publish), as well as reverting that back at some other date (unpublish). The wording of "publishing" is misleading here, since it actually should be a "swapping" process which allows to switch the live and version state of some element at any time.

Thus, now we can either remove the unpublish behavior completely (from TCA and AutoPublishService) or "enable" this feature again (adding it to TCA types again) & providing better description and documentation.

Associated revisions

Revision af183b60 (diff)
Added by Benni Mack 7 months ago

[!!!][TASK] Remove auto-unpublishing of workspaces

Workspaces had a field called "unpublish_time" which was not accessible
for TYPO3 Core since TYPO3 4.5. The field was still processed, but never
in use due to side-effects.

The functionality has therefore been removed without substitution.

Resolves: #81950
Releases: master
Change-Id: I6d79b78246103ef485a4d9d0de791b03d10d08a5
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60482
Tested-by: TYPO3com <>
Tested-by: Tymoteusz Motylewski <>
Tested-by: Georg Ringer <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Tymoteusz Motylewski <>
Reviewed-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60482

#2 Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60482

#3 Updated by Benni Mack 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 6 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF