Bug #81983

JStop() in FormResultCompiler handles Stylesheets but not JavaScript

Added by David Bruchmann over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-07-27
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The function is remarkable wrong and noted like this:

    /**
     * JavaScript code added BEFORE the form is drawn:
     *
     * @return string A <script></script> section with JavaScript.
     */
    public function JStop()
    {
        $stylesheetHtml = [];
        foreach ($this->stylesheetFiles as $stylesheetFile) {
            $stylesheetHtml[] = '<link rel="stylesheet" type="text/css" href="' . $stylesheetFile . '" />';
        }
        return implode(LF, $stylesheetHtml);
    }

History

#1 Updated by David Bruchmann over 2 years ago

In Version 8 the function looks like this:

    /**
     * JavaScript code added BEFORE the form is drawn:
     *
     * @return string
     * @deprecated since TYPO3 v8, will be removed in TYPO3 v9
     */
    public function JStop()
    {
        GeneralUtility::logDeprecatedFunction();
        return $this->addCssFiles();
    }

#2 Updated by Georg Ringer over 2 years ago

  • Status changed from New to Closed

as you found out the method is deprecated and removed in current master already. use addCssFiles()

Also available in: Atom PDF