Bug #82092

Document that TYPO3 CMS 7.6 is not compatible with MySQL strict modes

Added by Sybille Peters about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Documentation
Target version:
-
Start date:
2017-08-12
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

It is still necessary to use MySQL strict mode for TYPO3 7.6.21

I just tested this and ran into the already known "SQL error" when trying to create a page in a bare TYPO3 system. ("SQL error: 'Incorrect integer value: '' for column 'storage_pid' at row 1'")

For TYPO3 8, MySQL strict mode is apparently supported: https://forge.typo3.org/issues/72610

The "system requirements" page does not mention strict mode (which is probably ok since the currently supported version is TYPO3 8) but the other obvious sources for TYPO3 7.6 did not either, e.g. see here:

The Install.md for TYPO3 6.2 mentions strict mode: https://github.com/TYPO3/TYPO3.CMS/blob/TYPO3_6-2/INSTALL.md

It would be even better to also check for strict mode on the environment check on FIRST_INSTALL but I will see if there is already an issue for this and if not I will create one ...

Since strict mode is officially supported in TYPO3 8 and TYPO3 8 is the current LTS version, the problem is not so severe but there still may be people using TYPO3 7.6.


Related issues

Related to TYPO3 Core - Task #54883: Document that TYPO3 CMS is not compatible with MySQL strict modes Closed 2014-01-09

History

#1 Updated by Sybille Peters about 2 years ago

  • Related to Task #54883: Document that TYPO3 CMS is not compatible with MySQL strict modes added

#2 Updated by Sybille Peters about 2 years ago

On further investigating it seems the error occurred because compatibility6 was installed. AFAIK TYPO3 7.6 works with "strict mode".

So this issue is not related to the core and can be closed. Sorry.

#3 Updated by Wouter Wolters about 2 years ago

  • Status changed from New to Closed

closed as requested.

Also available in: Atom PDF