Bug #82114

OnlineMedia Processing forces FAL drivers to extend AbstractDriver

Added by Franz Koch about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-08-16
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

FAL drivers are not obligated to extend the AbstractDriver but only to implement the DriverInterface. Having custom drivers that are not based on AbstractDriver (because they are f.e. non hierarchical) currently causes an Exception because \TYPO3\CMS\Core\Resource\OnlineMedia\Processing\PreviewProcessing expects an instance of AbstractDriver as method argument and not DriverInterface.

Patch/fix is already on Gerrit. Ticket only for reference.

Associated revisions

Revision 5dac1cf4 (diff)
Added by Franz Koch about 2 years ago

[BUGFIX] Use DriverInterface instead AbstractDriver for method signature

FAL drivers are not obligated to extend the AbstractDriver but only
to implement the DriverInterface. Having custom drivers that are not
based on AbstractDriver (because they are f.e. non hierarchical)
currently causes an Exception because PreviewProcessing expects an
instance of AbstractDriver as method argument.

This patch changes te signature from AbstractDriver to DriverInterface.

Resolves: #82114
Releases: master, 8.7, 7.6
Change-Id: Ia27c6c1c7510ecfe5afd0f7d8bedf81bf3d31c84
Reviewed-on: https://review.typo3.org/53714
Reviewed-by: Frans Saris <>
Tested-by: TYPO3com <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision ed11f88a (diff)
Added by Franz Koch about 2 years ago

[BUGFIX] Use DriverInterface instead AbstractDriver for method signature

FAL drivers are not obligated to extend the AbstractDriver but only
to implement the DriverInterface. Having custom drivers that are not
based on AbstractDriver (because they are f.e. non hierarchical)
currently causes an Exception because PreviewProcessing expects an
instance of AbstractDriver as method argument.

This patch changes te signature from AbstractDriver to DriverInterface.

Resolves: #82114
Releases: master, 8.7, 7.6
Change-Id: Ia27c6c1c7510ecfe5afd0f7d8bedf81bf3d31c84
Reviewed-on: https://review.typo3.org/53725
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 38eb30d6 (diff)
Added by Franz Koch about 2 years ago

[BUGFIX] Use DriverInterface instead AbstractDriver for method signature

FAL drivers are not obligated to extend the AbstractDriver but only
to implement the DriverInterface. Having custom drivers that are not
based on AbstractDriver (because they are f.e. non hierarchical)
currently causes an Exception because PreviewProcessing expects an
instance of AbstractDriver as method argument.

This patch changes te signature from AbstractDriver to DriverInterface.

Resolves: #82114
Releases: master, 8.7, 7.6
Change-Id: Ia27c6c1c7510ecfe5afd0f7d8bedf81bf3d31c84
Reviewed-on: https://review.typo3.org/53684
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53714

#2 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53714

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53725

#4 Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53684

#5 Updated by Franz Koch about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Gerrit Code Review about 2 years ago

  • Status changed from Resolved to Under Review

Patch set 5 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/53684

#7 Updated by Franz Koch about 2 years ago

  • Status changed from Under Review to Resolved

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF