Bug #82128

Database migration/analyzer fail on VARCHAR default NULL

Added by Jakob Berlin about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-08-17
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In install tool after running "Database analyzer" I get proposed queries like:

ALTER TABLE tablename CHANGE field zzz_deleted_field varchar(255) NOT NULL default NULL;

This is not working as a Not-Null-Field could not setup as default null obviously.

Is this a problem of the created field which was tx_sffeuser_corpcountry here or could it (maybe never the less) handled by SqlSchemaMigrationService to avoid such queries?

History

#1 Updated by Jakob Berlin about 2 years ago

Obvious workaround if someone run into this:

Run the query on the database directly but modified e.g. to:

ALTER TABLE tablename CHANGE field zzz_deleted_field varchar(255) default NULL;

#2 Updated by Wouter Wolters about 2 years ago

  • Status changed from New to Needs Feedback

Is this a problem on version 8.7?

#3 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

Moreover, the whole codebase has changed in this regard (TYPO3 8.7.x uses Doctrine) and we won't change this anymore for version 7.

If you think that this is the wrong decision, please reopen it or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF