Task #82487

Revert TemplatePaths optimizations and regressions

Added by Benni Mack about 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Fluid
Target version:
Start date:
2017-09-14
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #82196: Can no longer configure diverging templateRootPaths for the view of each plugin in an extension Needs Feedback 2017-08-24
Related to TYPO3 Core - Bug #82181: Cannot override plugin view.templateRootPaths because of cache Closed 2017-08-23
Related to TYPO3 Core - Bug #79662: Fluid caches default view paths Needs Feedback 2017-02-07

Associated revisions

Revision d4f52cc5 (diff)
Added by Benni Mack about 2 years ago

[TASK] Revert "Remove runtime cache and early return from TemplatePaths"

This reverts commit 30c467196034ffdedc35e4be205ab4acec28a8c6
due to several side effects.

Change-Id: I43586802a9838faa2723fdcaa2e9e15492003830
Resolves: #82487
Reverts: #82196
Reverts: #82181
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54144
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision f820b35b (diff)
Added by Benni Mack about 2 years ago

[TASK] Revert "Remove runtime cache and early return from TemplatePaths"

This reverts commit 6e02927806218e7b9b84310ea735ded578433c02
due to several side effects.

Change-Id: I8d58ebef93c6bb4c81ea894a4a815c118d95d1dc
Resolves: #82487
Reverts: #82196
Reverts: #82181
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54145
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 75e9b2a1 (diff)
Added by Benni Mack about 2 years ago

[BUGFIX] Revert "Improve performance of Fluid TemplatePaths"

This reverts commit 8d355f5479af72fcc716f29d69ac765b2beab733
due to side-effects introduced with this commit.

Change-Id: I51a4241c5d08021415f7300bb6e81489b4dd7fd9
Resolves: #82487
Reverts: #82232
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54146
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 2804b1c6 (diff)
Added by Benni Mack about 2 years ago

[BUGFIX] Revert "Improve performance of Fluid TemplatePaths"

This reverts commit 31310553bdfe724fd3be0d968cd2b4830bec24b0
due to side-effects introduced with this commit.

Change-Id: I67680820b0e139fea49cfcc0818cd97af3f6b9b9
Resolves: #82487
Reverts: #82232
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54147
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Benni Mack about 2 years ago

  • Related to Bug #82196: Can no longer configure diverging templateRootPaths for the view of each plugin in an extension added

#2 Updated by Benni Mack about 2 years ago

  • Related to Bug #82181: Cannot override plugin view.templateRootPaths because of cache added

#3 Updated by Benni Mack about 2 years ago

  • Related to Bug #79662: Fluid caches default view paths added

#4 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54144

#5 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54145

#6 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54144

#7 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54145

#8 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54146

#9 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54147

#10 Updated by Benni Mack about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF