Feature #82617

Cannot disable grid tier classes

Added by Juan Manuel Vergés Solanas over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2017-09-29
Due date:
% Done:

0%

Estimated time:
PHP Version:
7.0
Tags:
Complexity:
Sprint Focus:

Description

Fields inside GridRow.
If you set for example a field with Lg 6 and Xs 6, but you don't set Md and Sm the result html classes include Md 1 and Sm 1 even this is not set in the Yaml file.

Maybe GridRow could have a checkbox checked by default with some label like "Autocalculate columns width" instead of "Leave empty for auto calculation" in each Field or having that checkbox per Grid viewport configuration in the field.

#1

Updated by Mathias Brodala over 4 years ago

  • Subject changed from ext:form Fields inside GridRow to Cannot disable grid tier classes
  • Category set to Form Framework
#2

Updated by Bjoern Jacob almost 4 years ago

  • Sprint Focus set to Remote Sprint
#3

Updated by Bjoern Jacob almost 4 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Needs Feedback
  • Assignee set to Juan Manuel Vergés Solanas

I think this is not a bug. I have created a new Grid Row and added 3 fields. The first field has the display settings as defined by you (XS 6, LG 6). The resulting classes are:

  • col-xs-6 col-sm-4 col-md-4 col-lg-6
  • col-xs-3 col-sm-4 col-md-4 col-lg-3
  • col-xs-3 col-sm-4 col-md-4 col-lg-3

IMHO the system behaves as exptected.

What do you want to achieve? Would it help you if you could remove a concrete viewport configuration?

#4

Updated by Bjoern Jacob over 3 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Juan Manuel Vergés Solanas)
  • Sprint Focus deleted (Remote Sprint)

No Feedback since nearly 3 months. I am closing this issue. If the problem still exists please re-open this issue or create a new one. Thx mate!

Also available in: Atom PDF