Bug #82797

PageLinkBuilder uses $absoluteUrlScheme outside of forceAbsoluteUrl but the scheme can only be changed when using forceAbsoluteUrl

Added by Wolfgang Klinger over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2017-10-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

$absoluteUrlScheme is also used for e.g. building links to other domains inside the same installation but the scheme can't be changed in this case (= hardcoded to http).

Related: #32343


Related issues

Related to TYPO3 Core - Feature #32343: Default value for url_schemeRejected2011-12-06

Actions
Is duplicate of TYPO3 Core - Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrlClosed2018-05-29

Actions
#1

Updated by Wolfgang Klinger over 3 years ago

#2

Updated by Stephan Großberndt over 2 years ago

  • Related to Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrl added
#3

Updated by Stephan Großberndt over 2 years ago

  • Related to deleted (Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrl)
#4

Updated by Stephan Großberndt over 2 years ago

  • Is duplicate of Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrl added
#5

Updated by Stephan Großberndt over 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF