Bug #82875

Check license compatibility upon extension upload to TER

Added by Bernhard Kraft over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2017-10-27
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When uploading an extension to TER there is a checkbox:

"I confirm that my extension contains only GPL v2 or any later version compliant code"

It should additionally be checked that the code uses an acceptable license by having a "license => 'GPLv2'" attribute in ext_emconf or by checking the already existing "license" property in a composer.json file.

In my eyes there should be an exact version requirement: "GPLv2, GPLv3, LGPL or MIT license".

I would not want my extension to get integrated into some GPLv4 apps - if there would be a GPLv4 and I would not have (could not have) read it.

I do not know whether this belongs to the new extension repository issues. I have no account there.


Related issues

Related to TYPO3 Core - Bug #82774: Check license compatibility upon extension install Closed 2017-10-16
Related to Licensing Team - Task #50133: License compatibility Needs Feedback 2013-07-17

History

#1 Updated by Bernhard Kraft over 1 year ago

  • Related to Bug #82774: Check license compatibility upon extension install added

#2 Updated by Jo Hasenau over 1 year ago

As already mentioned in #82774 the checkbox label states:

I confirm that my extension contains only GPL v2 or any later version compliant code.

This includes any GPL vX which is available now or in the future and it includes more than just 'GPLv2, GPLv3, LGPL or MIT'.
If you do not agree to these terms, you should not make use of the TER in any direction.

Please discuss topics like that with the licensing team first, since we are using our own tracker here on forge.

#3 Updated by Nicole Cordes over 1 year ago

  • Status changed from New to Rejected

Hi Bernhard,

I don't think it is necessary to add any additional code check if the user already declines (by checking the checkbox actively) that the extension and its code is compatible to GPL 2 or later.

As this ticket neither belongs to the Extension Manager nor to TYPO3 core, I'm closing this one. If you feel misunderstood, please open a ticket in the TER issue tracker at https://git-t3o.typo3.org/t3o/ter/issues.

Thank you very much.

#4 Updated by Jo Hasenau over 1 year ago

Also available in: Atom PDF