Task #83030

Vimeo/Youtube needs to save the video id

Added by Christoph Hendreich almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-11-17
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Sprint Focus:

Description

Hi all,

the problem is if we put a FAL Media over Vimeo/Youtube inside: Example "https://vimeo.com/66651032"
Normally the sys_file must have then the name "66651032.vimeo".
But this is named "TEST_VIDEO.vimeo" after savefing.

Now the problem is nobody can work with a video id of TEST_VIDEO. Because if someone will work with the vimeo or youtube API they need the fixed video id.

Is there a possiblity to safe the filename generally in 66651032.vimeo?
Or a new database field with content of the Video ID 66651032?

Best Regards Christoph

History

#1 Updated by Christoph Hendreich almost 3 years ago

  • Subject changed from Vimeo/Youtube needs to save with the video id to Vimeo/Youtube needs to save the video id

#2 Updated by Mathias Schreiber almost 3 years ago

Hi Christoph,

can you define "work with" in this scenario?

#3 Updated by Frans Saris almost 3 years ago

  • Status changed from New to Needs Feedback

The contents of the file is the video id.

So in fluid you can do {file.contents} to get the id.

In extbase context {file.originalResourcr.contents}

Is this enough or do you have a different usecase to solve?

#4 Updated by Christoph Hendreich almost 3 years ago

Mathias Schreiber wrote:

Hi Christoph,

can you define "work with" in this scenario?

The problem is if someone will work with an API of YouTube, Video etc. you need to have the correct video id.

Small example:
When you will load some details (name, views, etc) of the video via json or xml, you need the id of the video and this is not saved into the database. So now my first idear was to load the sys_file.name of the video, str_replace the .vimeo and the id is correct. But the problem is that typo3 save the name of the video not the id.

Cheers Chris

#5 Updated by Christoph Hendreich almost 3 years ago

Frans Saris wrote:

The contents of the file is the video id.

So in fluid you can do {file.contents} to get the id.

In extbase context {file.originalResourcr.contents}

Is this enough or do you have a different usecase to solve?

Thanks this helps me {file.contents}, can you tell me where where the data is stored in the database?

#6 Updated by Frans Saris almost 3 years ago

This id isn't in the database

The contents of the file is the video id

The *.vimeo and *.youtube are just text files that only contain the id as normal string.

#7 Updated by Wouter Wolters over 2 years ago

  • Status changed from Needs Feedback to Closed

Answer is given to the question, no further questions asked. Closing this one as solved.

Also available in: Atom PDF