Bug #83152

TCA migration should check that all TCA columns have a config section

Added by Benni Mack almost 4 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
System/Bootstrap/Configuration
Target version:
Start date:
2017-11-29
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

See related issues.


Related issues

Related to TYPO3 Core - Bug #73076: Publishing of changed sys_file_metadata fails because of missing config array for with and height fieldsClosed2016-02-02

Actions
#1

Updated by Benni Mack almost 4 years ago

  • Related to Bug #73076: Publishing of changed sys_file_metadata fails because of missing config array for with and height fields added
#2

Updated by Christian Kuhn almost 4 years ago

TcaMigration: verify for all ['columns'][*] ['config']['type'] (and thus ['config']) exists, if not, set to type=none and create migration issue.

#3

Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54857

#4

Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54857

#5

Updated by Christian Kuhn almost 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF