Bug #83244

Fluid Widget Links: Do not use cHash by default

Added by Benni Mack about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Fluid
Target version:
Start date:
2017-12-06
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently, when using fluid widgets, cHash cannot be deactivated.

Additionally, using cHash and addQueryString is counterproductive, thus should be avoided by default.


Related issues

Related to TYPO3 Core - Task #84537: Backport useCacheHash argument for widget links Closed 2018-03-27

Associated revisions

Revision b2d34992 (diff)
Added by Benni Mack about 2 years ago

[!!!][BUGFIX] Fluid Widget Links: Do not use cHash by default

When using the widget.link viewhelper, it is not possible to create links
without cHash.

In order to achieve this, cHash is only appended, if "useCacheHash" is
activated (addQueryString is always added, which makes sense due to the
parameters for the link).

As this is a breaking bugfix, it can only go in master.

Resolves: #83244
Resolves: #61960
Releases: master
Change-Id: I1c2dcf159a107188fd744f32de60809d15831162
Reviewed-on: https://review.typo3.org/54967
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Jigal van Hemert <>
Tested-by: Jigal van Hemert <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision c36a144c (diff)
Added by Georg Ringer over 1 year ago

[FEATURE] Make cHash configurable in Fluid Widget Links

To be able to support TYPO3 9 and 8 with same templates, the issue
#83244 is backported to 8 as well. The default value is set to true
to make it non breaking.

Resolves: #84537
Releases: 8.7
Change-Id: I45e51ba58fd32c7577d5cd0a67f36884ed7ce57a
Reviewed-on: https://review.typo3.org/56463
Reviewed-by: Markus Klein <>
Tested-by: TYPO3com <>
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54967

#2 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54967

#3 Updated by Benni Mack about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Markus Klein over 1 year ago

  • Related to Task #84537: Backport useCacheHash argument for widget links added

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF