Bug #83280

Use stateIdentifier instead of Uid for SVG tree nodes

Added by Paweł Rogowicz about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Category:
Pagetree
Target version:
Start date:
2017-12-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Change Uid to stateIdentifier because one Uid can occur in the pagetree
many times, for example in DB mounts.
We need to know what node is visible or what node was clicked or what
node was mouse over / mouse leave, e.t.c.

Associated revisions

Revision f3e5b077 (diff)
Added by Paweł Rogowicz about 2 years ago

[BUGFIX] Use stateIdentifier instead of Uid for SVG tree nodes

Change Uid to stateIdentifier because one Uid can occur in the pagetree
many times, for example in DB mounts.
We need to know what node is visible or what node was clicked or what
node was mouse over / mouse leave, e.t.c.

This change also fixes:
- fix MP title position and visibility
- fix changing node name when the same node is multiple in page tree
(pagetree, mount points)
- modified the acceptance tests

Releases: master
Resolves: #83280
Change-Id: I57716db1f2850f0c4b1432651ed391ece5921fec
Reviewed-on: https://review.typo3.org/55020
Tested-by: TYPO3com <>
Tested-by: Stefan Neufeind <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>
Reviewed-by: Alexander Opitz <>
Tested-by: Alexander Opitz <>

Revision d9584f3b (diff)
Added by Paweł Rogowicz about 2 years ago

[BUGFIX] Change data-uid to data-state-id

Change data-uid to data-state-id because there isn't uid just state identifier

Releases: master
Resolves: #83280
Change-Id: Ia0a57c061c4cff7ce6969a5a9ccc4398b81ba202
Reviewed-on: https://review.typo3.org/55033
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#2 Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#3 Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#4 Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#5 Updated by Gerrit Code Review about 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#6 Updated by Gerrit Code Review about 2 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55020

#7 Updated by Tymoteusz Motylewski about 2 years ago

  • Subject changed from Improve SVG page tree to Use stateIdentifier instead of Uid for SVG tree nodes

#8 Updated by Tymoteusz Motylewski about 2 years ago

  • Description updated (diff)

#9 Updated by Gerrit Code Review about 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55033

#10 Updated by Paweł Rogowicz about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF