Bug #83434

Image Manipulation Wizard works for first 17 images only

Added by Stefan Froemken almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-12-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I work with content element "image" and have added and saved 40 images. After reload the Image Manipulation Wizard works for first 17 images only. The wizard button for all further images saves the current content element.

Stefan

#1

Updated by Frans Saris almost 4 years ago

Do you get any JavaScript errors?

#2

Updated by Stefan Froemken almost 4 years ago

No. I get a "Notification API is deprecated" message only

#3

Updated by Stefan Froemken almost 4 years ago

Ok. I get a JavaScript error when I open the image manipulation wizard of the last working image:

Uncaught TypeError: Cannot read property 'cropper' of null
at HTMLImageElement.ImageManipulation.cropBuiltHandler (ImageManipulation.js?bust=3c7775a2cf897d64dd17c03bd36809a5d2ac23a0:50)
at HTMLImageElement.e (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:3)
at HTMLImageElement.dispatch (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:3)
at HTMLImageElement.q.handle (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:3)
at Object.trigger (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:4)
at HTMLImageElement.<anonymous> (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:4)
at Function.each (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:2)
at r.fn.init.each (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:2)
at r.fn.init.trigger (jquery-3.2.1.min-aee6751182284a03cf6261d0e0b64a80.js.gzip:4)
at v.trigger (cropper.min.js?bust=3c7775a2cf897d64dd17c03bd36809a5d2ac23a0:10)

TYPO3 8.7.10-dev

#4

Updated by Stefan Froemken almost 4 years ago

I have opened the right frame in a new tab. Same problem. But when I open the developer toolbar in google chrome with "disable cache" and save the content element again, than it works.

I have set max_input_vars to 3000, but the problem is still present.

#5

Updated by Stefan Froemken almost 4 years ago

The button has CSS class t3js-image-manipulation-trigger assigned. I have checked the event listeners for each button in Chrome. Only the first 17 images have function triggerHandler assigned. All other buttons does not have this trigger assigned, which will currently send the save request.
Idea: Processing the response needs 8 seconds to render the 40 images in my content element. Maybe assigning the trigger to the buttons starts too early?

#6

Updated by Stefan Froemken almost 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

It works in Safari. It works in Firefox and it works in incognito tab of google chrome. After clearing over 400 MB of cache files in Google chrome, it works. Thank you for your help. I'm closing this issue now.

Also available in: Atom PDF