Bug #83438

Respect suomi in specCharsToASCII conversion method

Added by Dan Untenzu almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-12-28
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 offers a method to convert a string with special characters like German Umlauts (ä, ö, ü, …) to ASCII (ae, oe, ue, …), in order to convert filenames, URLs, etc.

This method is imho not able to handle different language settings for umlauts. For example in Finland, the »ä« is also present in the language (suomi) and should be converted to »a« instead. See example page:

This issue was reported first in RealURL: https://github.com/dmitryd/typo3-realurl/issues/584#issuecomment-353553366

Method specCharsToASCII: https://api.typo3.org/typo3cms/8/html/_charset_converter_8php_source.html#l01268


Related issues

Duplicates TYPO3 Core - Bug #20612: scandinavian letters are translittered wrong Needs Feedback 2009-06-12

History

#1 Updated by Reiner Teubner almost 2 years ago

IMO: The method works like it's expected behavior because in utf-8 we can't recognize which origin language is it.

#2 Updated by Markus Klein almost 2 years ago

  • Duplicates Bug #20612: scandinavian letters are translittered wrong added

#3 Updated by Markus Klein almost 2 years ago

  • Status changed from New to Closed

This is more or less a duplicate of #20612.

As Reiner already mentioned, this is not really solvable as it looks.

A solution for your issue is to set [SYS][utf8filesystem] so no transliteration has to be performed.

#4 Updated by Dan Untenzu almost 2 years ago

Ah, I see, thanks for the reference.

Sidenote - As long as the original issue #20612 is not solved we have provided two solutions for this:

Also available in: Atom PDF