Bug #83618

Using individual (subtree split) packages does not work for TYPO3 8

Added by Helmut Hummel 29 days ago. Updated 26 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-01-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since entry point generation was changed to be done in TYPO3 code instead of composer installers code
and no code for that has been added to 8 branch, it is currently not possible to get a working state
when using subtree split packages with TYPO 8.

Associated revisions

Revision 8fb1559c (diff)
Added by Helmut Hummel 26 days ago

[BUGFIX] Generate entry points for subtree split packages

Add dependency to a composer package that generates
the entry points for TYPO3 in versions 8.7.*
to typo3/cms-core

This resolves issues with users trying to use subtree split packages
with composer for TYPO3 8.7 and them ending up in a not usable state
as entry points are missing.

Also re-sync dependencies with root composer.json file

Resolves: #83618
Releases: 8.7
Change-Id: I13adcc03b476d22798fc1cfa6882ce155d9017b4
Reviewed-on: https://review.typo3.org/55414
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

History

#1 Updated by Gerrit Code Review 29 days ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55414

#2 Updated by Gerrit Code Review 29 days ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55414

#3 Updated by Helmut Hummel 26 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF