Bug #83627

Epic #83669: Improve file list / file browser

EXT:filelist Exception when creating a new text file with a non LocalDriver

Added by Michael Oehlhof over 1 year ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2018-01-21
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After creating the text file the URL parameter target for editing the text file is not composed from the right parameters.

This works with the LocalDriver because its identifier is a combination of path and filename. But with other storages which uses an independent identifier this results with an exception.

#1329647780: Object with identifier "3:721a47b2-97ed-4002-82da-f64daeabdb93testfile_1.txt" does not exist in storage

For testing the Teamruhr FAL Driver (Version >= 2.0.2) can be used.
https://extensions.typo3.org/extension/teamruhr_fal_driver/

Associated revisions

Revision e643a092 (diff)
Added by Michael Oehlhof over 1 year ago

[BUGFIX] EXT:filelist Fixed exception when creating new text file

The exception does not occur with the LocalDriver.
For testing use the driver mentioned in the forge issue.

Resolves: #83627
Releases: master, 8.7
Change-Id: Iae5fef2cc1ca704998975aba4fb6f5e48aeec4b1
Reviewed-on: https://review.typo3.org/55419
Tested-by: TYPO3com <>
Reviewed-by: Markus Klein <>
Reviewed-by: Henning Liebe <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>
Reviewed-by: Jan Stockfisch <>
Tested-by: Jan Stockfisch <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision fd9969bf (diff)
Added by Michael Oehlhof over 1 year ago

[BUGFIX] EXT:filelist Fixed exception when creating new text file

The exception does not occur with the LocalDriver.
For testing use the driver mentioned in the forge issue.

Resolves: #83627
Releases: master, 8.7
Change-Id: Iae5fef2cc1ca704998975aba4fb6f5e48aeec4b1
Reviewed-on: https://review.typo3.org/55809
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Michael Oehlhof over 1 year ago

You need version 2.0.3 of the Teamruhr FAL Driver, because of an sql error on first time creation of the storage.

If you want to create more than one storages with this driver you need version 2.0.4

#2 Updated by Michael Oehlhof over 1 year ago

  • TYPO3 Version changed from 9 to 8

#3 Updated by Gerrit Code Review over 1 year ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55419

#4 Updated by Michael Oehlhof over 1 year ago

  • Parent task set to #82206

#5 Updated by Riccardo De Contardi over 1 year ago

  • Parent task changed from #82206 to #83669

#6 Updated by Michael Oehlhof over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Gerrit Code Review over 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55809

#8 Updated by Michael Oehlhof over 1 year ago

  • Status changed from Under Review to Resolved

#9 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF