Bug #84010

Checkmarks in Linkvalidator report still do not work correctly

Added by Sybille Peters about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Linkvalidator
Target version:
-
Start date:
2018-02-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Will probably happen in TYPO3 8 and 9, I am only testing with current master (9.2.0-dev)

Steps to reproduce

  1. Use a fresh install or reset your user settings: Click on user name in top : "user settings" : "Edit and Advanced functions" : "Reset user settings to default state"
  2. Go to a page where invalid links exist
  3. Info: Linkvalidator: "Check links"
  4. Look at the report:

Actual results

By default none of the links types will be checked in the report. However, invalid links are shown in the list.

Also, if you click only on "Internal Links" type checkbox, then on refresh, deselect the checkbox again, refresh, this does not work correctly.

#1

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55872

#2

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55872

#3

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55872

#4

Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55872

#5

Updated by Sybille Peters about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Gerrit Code Review about 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55966

#7

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55966

#8

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55966

#9

Updated by Gerrit Code Review about 3 years ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55966

#10

Updated by Sybille Peters about 3 years ago

  • Status changed from Under Review to Resolved
#11

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF