Bug #84071

Exception Call to a member function getTreeList() on null

Added by Manuel Selbach about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2018-02-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If there is a DataProcessor used in a FLUIDTEMPLATE object which tries to resolve storagePids from the configuration with recursion set,
the following exception occurs:

Call to a member function getTreeList() on null

Error thrown in file
typo3/cms/typo3/sysext/extbase/Classes/Configuration/FrontendConfigurationManager.php in line 258.
30 TYPO3\CMS\Extbase\Configuration\FrontendConfigurationManager::getRecursiveStoragePids("-8", 3)

typo3/cms/typo3/sysext/extbase/Classes/Configuration/AbstractConfigurationManager.php:
00198:                 $frameworkConfiguration['persistence']['storagePid'] = $this->getRecursiveStoragePids(
00199:                     implode(',', $storagePids),
00200:                     (int)$frameworkConfiguration['persistence']['recursive']
00201:                 );
00202:             }

This is, because the running order has changed with this change https://github.com/TYPO3/TYPO3.CMS/commit/5c048a4c8017e4d50ab5f2343970a0fd33e4aaed in TYPO3\CMS\Frontend\ContentObject\FluidTemplateContentObject::render.

If you follow into TYPO3\CMS\Fluid\View\StandaloneView::construct (which was previously executed before the execution of dataProcessors were called) the method TYPO3\CMS\Extbase\Configuration\ConfigurationManager::setContentObject is called.

As this is not valid now, the method TYPO3\CMS\Extbase\Configuration\FrontendConfigurationManager::getRecursiveStoragePids tries to retrieve data from "null" which throws the mentioned exception.

#1

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55928

#2

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55928

#3

Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56035

#4

Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56045

#5

Updated by Benjamin Franzke about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF