Bug #84200

Unknown palette "language" referenced in filemetadata extension's TCA configuration

Added by Christian Heindl over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2018-03-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

The TCA override/extension for the table sys_file_metadata in filemetadata extension incorrectly references a palette named "language", which does not exist. This results in an empty "language" tab, when editing a files metadata.

Instead of the palette the field should be directly referenced.

I will submit a patch soon.


Related issues

Related to TYPO3 Core - Bug #85711: File language field is rendered twice and sys_language_uid is never rendered in sys_file_metadata Closed 2018-08-01

Associated revisions

Revision 1a74c8c9 (diff)
Added by Christian Heindl over 2 years ago

[BUGFIX] Correctly reference sys_file_metadata.language in TCA

Palette "language" does not exists on table "sys_file_metadata" resulting
in an empty "language" tab, when editing a file's metadata.
Thus referencing language field directly.

Releases: master, 8.7
Resolves: #84200
Change-Id: I44b2b169bbce7948826fdade9f10a760b32df2c7
Reviewed-on: https://review.typo3.org/56099
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision 58e987e5 (diff)
Added by Christian Heindl over 2 years ago

[BUGFIX] Correctly reference sys_file_metadata.language in TCA

Palette "language" does not exists on table "sys_file_metadata" resulting
in an empty "language" tab, when editing a file's metadata.
Thus referencing language field directly.

Releases: master, 8.7
Resolves: #84200
Change-Id: I44b2b169bbce7948826fdade9f10a760b32df2c7
Reviewed-on: https://review.typo3.org/56148
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>

Revision 2f3577d7 (diff)
Added by Helmut Hummel almost 2 years ago

[BUGFIX] Correctly render language fields of sys_file_metadata

This reverts commit 1a74c8c9d302958dd17b6a35c03e185f13811c4b
("[BUGFIX] Correctly reference sys_file_metadata.language in TCA"),
that replaced the rendering of sys_language_uid and l10n_parent
with the file language field, which was since then rendered twice.

We now correctly render the hidden language palette in the general tab
and remove the language tab, which was empty after the palette has been
hidden.

Resolves: #85711
Related: #84200
Related: #75040
Releases: master, 8.7
Change-Id: I18ab907bc48f81b257d3af42c4278d6688166b2f
Reviewed-on: https://review.typo3.org/57760
Reviewed-by: Moritz Ngo <>
Tested-by: Moritz Ngo <>
Reviewed-by: Dennis Oezet <>
Tested-by: Dennis Oezet <>
Tested-by: TYPO3com <>
Reviewed-by: Markus Volkmer <>
Tested-by: Markus Volkmer <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

Revision 3712c7cb (diff)
Added by Nicole Cordes almost 2 years ago

[BUGFIX] Correctly render language fields of sys_file_metadata

This reverts commit 1a74c8c9d302958dd17b6a35c03e185f13811c4b
("[BUGFIX] Correctly reference sys_file_metadata.language in TCA"),
that replaced the rendering of sys_language_uid and l10n_parent
with the file language field, which was since then rendered twice.

We now correctly render the hidden language palette in the general tab
and remove the language tab, which was empty after the palette has been
hidden.

Resolves: #85711
Related: #84200
Related: #75040
Releases: master, 8.7
Change-Id: I18ab907bc48f81b257d3af42c4278d6688166b2f
Reviewed-on: https://review.typo3.org/57761
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Markus Volkmer <>
Tested-by: Markus Volkmer <>
Reviewed-by: Moritz Ngo <>
Tested-by: Moritz Ngo <>
Reviewed-by: Dennis Oezet <>
Tested-by: Dennis Oezet <>
Tested-by: TYPO3com <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56099

#2 Updated by Christian Heindl over 2 years ago

  • Category set to File Abstraction Layer (FAL)

#3 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56099

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56099

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56099

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56148

#7 Updated by Christian Heindl over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Helmut Hummel almost 2 years ago

  • Related to Bug #85711: File language field is rendered twice and sys_language_uid is never rendered in sys_file_metadata added

#9 Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF