Bug #84264

Backend not scrollable

Added by swanage no-lastname-given over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-03-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since 8.7.11 the backend is no longer scrollable.
Left pane not scrollable in Page, List etc. view.
I tried Chromium, Chrome and Firefox.

!Screenshot_from_2018-03-14 15-22-31.png!


Files

Screenshot_from_2018-03-14 15-22-31.png (153 KB) Screenshot_from_2018-03-14 15-22-31.png Missing scrollbar swanage no-lastname-given, 2018-03-14 15:25

Related issues

Related to TYPO3 Core - Bug #84263: Backend Content not scrollable if only DebuggerUtility::var_dumpClosed2018-03-14

Actions
Related to TYPO3 Core - Bug #84476: Backend Scrolling own ExtensionClosed2018-03-19

Actions
Related to TYPO3 Core - Task #84522: Fix for Backend not scrollableClosed2018-03-23

Actions
#1

Updated by swanage no-lastname-given over 3 years ago

  • Related to Bug #84263: Backend Content not scrollable if only DebuggerUtility::var_dump added
#3

Updated by Claude Unterleitner over 3 years ago

Do you have installed the extension ckeditor_fix as I did?
After deinstalling it, the backend was again scrollable.

#4

Updated by Stephan Großberndt over 3 years ago

  • Description updated (diff)
  • Status changed from New to Needs Feedback
#5

Updated by swanage no-lastname-given over 3 years ago

Correction: Most right pane is not scrollable (It is not even Monday)

#6

Updated by Sven Juergens over 3 years ago

hi, have you installed the extension "ckeditor bugfix for #80116"

Deinstall and all is scrolling is working again, the fix is now part auf TYPO3 core

#7

Updated by swanage no-lastname-given over 3 years ago

Indeed, the problem was in this fix. thank you all!

I love to work with T3bootstrap from Sven Wappler.
He fixed the old problem in an earlier version.

In ../typo3conf/ext/ws_t3bootstrap/Resources/Public/CSS/Backend/mods.css I deleted:

/* https://forge.typo3.org/issues/80116 * Bugfix for Chrome Scroll Bug
*/

html {
overflow: auto;
}
body {
height: auto;
min-height: 100%;
overflow: visible;
}

Now all is working again.

#8

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed

Thank you for your quick feedback and for your findings, that will help other people who use the same extension :)

I hope it is right for you if I close this issue now as it is not core-related. If you think that this is the wrong decision please reopen it or ping me.

#9

Updated by Frans Saris over 3 years ago

  • Description updated (diff)
#10

Updated by Stephan Großberndt over 3 years ago

  • Related to Bug #84476: Backend Scrolling own Extension added
#11

Updated by Christian Eßl over 3 years ago

Still happening in 8.7.12 and there is no "ckeditor_fix" extension installed.

The iframe that includes an extension module is built this way:

<iframe name="list_frame" id="typo3-contentIframe" scrolling="no" class="scaffold-content-module-iframe t3js-scaffold-content-module-iframe"></iframe>

Notice the "scrolling=no". This fixes the problem:
https://review.typo3.org/#/c/56439/1/typo3/sysext/backend/Resources/Private/Templates/Backend/Main.html

#12

Updated by Riccardo De Contardi over 3 years ago

  • Related to Task #84522: Fix for Backend not scrollable added

Also available in: Atom PDF