Bug #84452

TypoScript stdWrap property round will never be called

Added by Stefan Froemken over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Category:
TypoScript
Target version:
Start date:
2018-03-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I have following TS:

page.123 = COA
page.123.10 = TEXT
page.123.10.value = 2.315
page.123.10.round.roundType = ceil
page.123.10.round.decimals = 2
page.123.10.wrap = |<br>
page.123.20 = TEXT
page.123.20.value = 2.315
page.123.20.round.roundType = floor
page.123.20.round.decimals = 2
page.123.20.wrap = |<br>
page.123.30 = TEXT
page.123.30.value = 2.315
page.123.30.round.roundType = round
page.123.30.round.decimals = 2
page.123.30.wrap = |<br>

But all these configurations result in an untouched value in frontend:

2.315
2.315
2.315

IMO it should be

3
2
2.32

Seems there is something wrong in ContentObjectRenderer

Stefan

#1

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56333

#2

Updated by Wouter Wolters over 3 years ago

  • Status changed from Under Review to Rejected

Not a bug.

Also available in: Atom PDF