Project

General

Profile

Actions

Bug #84617

closed

Generating package states stopped working as expected after updates in symfony/finder component

Added by Faton Haliti almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2018-04-04
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After updates in symfony/finder component https://github.com/symfony/finder/commit/c72995d9f5999b3fcdd8660c0c9690243252e1e1 running now "php vendor/bin/typo3cms install:generatepackagestates" is having trouble installing packages because of the real path.

The wrong path now is showin only for sysext and not for custom extension (e.g. ext:news).

How to replicate:
  1. Have one custom extension which also depends in "core" extension.
  2. Delete all extension in PackageStates.php
  3. Try to run in cli "php vendor/bin/typo3cms install:generatepackagestates"

Result:
[ UnexpectedValueException ]
The package "some extension" depends on "core" which is not present in the system.
Note: The reason for this error is the wrong path now because of symfony finder component

Expected result:

The following extensions have been added to the generated PackageStates.php file: core, extbase, fluid, ....

Suggestion:

A solution can be modifying PackageManager.php->registerPackagesFromConfiguration(...)

$sysExtension = strpos($stateConfiguration['packagePath'], 'sysext');
 if ($sysExtension !== false) {
      $packagePath = PathUtility::sanitizeTrailingSeparator($stateConfiguration['packagePath']);
  } else {
       $packagePath = PathUtility::sanitizeTrailingSeparator($this->packagesBasePath . $stateConfiguration['packagePath']);
 }

Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #84601: Installation fails with "extbase" not found exceptionClosed2018-04-04

Actions
Actions #1

Updated by Helmut Hummel almost 6 years ago

  • Is duplicate of Bug #84601: Installation fails with "extbase" not found exception added
Actions #2

Updated by Helmut Hummel almost 6 years ago

  • Status changed from New to Closed

thanks for the report.
a fix for that (adding a conflict) has been merged already.

closed as duplicate

Actions #3

Updated by Stephan Großberndt almost 6 years ago

  • Subject changed from Generating package states stoped working as expected after updates in symfony/finder component to Generating package states stopped working as expected after updates in symfony/finder component
Actions

Also available in: Atom PDF