Bug #84801

TYPO3/CMS/Backend/ValueSlider does not initialize sliders added after requiring the js module

Added by Jakob Berlin over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Target version:
Start date:
2018-04-19
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Form
Complexity:
Is Regression:
Sprint Focus:

Description

I've a model which has an inline model defined which itself uses slider to setup a value. When add the first inline object slider is shown. Add a second one will not show the slider anymore :(

base model

'type' => 'inline',

inline model

'slider' => [
                    'step' => 1,
                    'width' => 200,
                ],

Associated revisions

Revision add951cc (diff)
Added by Andreas Fernandez 7 months ago

[BUGFIX] Create new instance of ValueSlider per occurrence

This patch changes the behavior of the FormEngine internal ValueSlider
by creating a new instance per occurrence of the slider to fix issues
with sliders created in new or not loaded inline relations.

Due to the new structure of the module, it's moved into
FormEngine/FieldWizard.

Resolves: #90673
Resolves: #84801
Releases: master, 9.5
Change-Id: I80f2f2faeb37fb793b19cede7b629d8c415072d3
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63598
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Georg Ringer over 2 years ago

is it because there are 2 slider items or because the 2nd is inside an inline relation?

#2 Updated by B. Kausch 8 months ago

  • Category set to Backend JavaScript
  • Target version set to next-patchlevel
  • TYPO3 Version changed from 8 to 9

I can confirm this for Version 9 too. The main problem is the javascript module TYPO3/CMS/Backend/ValueSlider. Once it was required (at loadtime or later when some inline record is added, which needs the module), it can only initialize those sliders currently present on the page. When you add a second inline record with a slider input, nothing triggers the init process...

#3 Updated by B. Kausch 8 months ago

  • Subject changed from multiple slider | inline | TCA | Backend to TYPO3/CMS/Backend/ValueSlider does not initialize sliders added after requiring the js module

#4 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63598

#5 Updated by Andreas Fernandez 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF