Bug #84859

Story #84872: Refactor form configuration handling

Exceptions from Form Configuration files are not caught

Added by Benni Mack over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Form Framework
Target version:
Start date:
2018-04-25
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Duplicates TYPO3 Core - Bug #84777: Exception because of non existing form yaml after saving ContentElement Closed 2018-04-18

Associated revisions

Revision 4511fe7d (diff)
Added by Benni Mack over 1 year ago

[BUGFIX] Catch exceptions for invalid form configuration files

Resolves: #84859
Releases: master, 8.7
Change-Id: I64b14c87758178f76258bdbf747931b008d9a71c
Reviewed-on: https://review.typo3.org/56797
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Ralf Zimmermann <>
Tested-by: Ralf Zimmermann <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 25aede95 (diff)
Added by Benni Mack over 1 year ago

[BUGFIX] Catch exceptions for invalid form configuration files

Resolves: #84859
Releases: master, 8.7
Change-Id: I64b14c87758178f76258bdbf747931b008d9a71c
Reviewed-on: https://review.typo3.org/56816
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Ralf Zimmermann <>
Tested-by: Ralf Zimmermann <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56797

#2 Updated by Benni Mack over 1 year ago

  • Duplicates Bug #84777: Exception because of non existing form yaml after saving ContentElement added

#3 Updated by Ralf Zimmermann over 1 year ago

Test:

  • create a form
  • create a content element "Form"
  • select your form
  • delete the form definition from the filesystem
  • save the content element again

#4 Updated by Ralf Zimmermann over 1 year ago

  • Parent task set to #84872

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56816

#6 Updated by Benni Mack over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF