Bug #84906

Install Tool: Analyze Database Structure (DB compare) does not display any errors if there is an error in ext_tables.sql

Added by Sybille Peters over 2 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-05-01
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If there is any error in an ext_tables.sql the database analyzer does not show any changes that should get applied and not error message. It simply shows nothing.

Because of this, if there are any ext_tables.sql with invalid SQL, none of the changes in the database schema will get applied.

(Configuration preset: debug is selected)

History

#1 Updated by Georg Ringer 8 months ago

  • Status changed from New to Closed

this has been resolved in the meantime,

having e.g. following

CREATE TABLE fe_users (
    felogin_redirectPid  tinytext
    felogin_forgotHash  varchar(80) default ''
);


mind the missing , between the 2 cols, I get the following:
[SQL Error] line 0, col 54: Error: Expected NOT, NULL, DEFAULT, AUTO_INCREMENT, UNIQUE, PRIMARY, COMMENT, COLUMN_FORMAT, STORAGE or REFERENCES, got 'felogin_forgotHash' in statement: CREATE TABLE fe_users ( felogin_redirectPid tinytext felogin_forgotHash varchar(80) default '' );

Also available in: Atom PDF