Bug #85069

Linkvalidator reports links to pages with certain cookie-alerts as broken

Added by Loek Hilgersom about 3 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Linkvalidator
Target version:
-
Start date:
2018-05-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

External links to pages with a full screen cookie-alert are reported as broken, with this error in the report:

Exception: NAMEPREP: Prohibited input U+0000007E

Examples of such links:

https://www.ad.nl/
https://www.ed.nl/
https://www.gelderlander.nl/


Related issues

Related to TYPO3 Core - Bug #86921: Linkvalidator reports exception on links with tilde (~)Closed2018-11-13

Actions
#1

Updated by Sybille Peters over 2 years ago

  • Assignee deleted (Anonymous)
#2

Updated by Sybille Peters over 2 years ago

  • Status changed from New to Needs Feedback

I can't reproduce the problem with the 3 links you provided in 9 master.

It appears there may be some encoding / conversion problems, but it's difficult to look into this without a reproducable testcase or a stackdump where you can see on which code statements the exception was thrown.

If you can still reproduce this problem with the above or other links, please add more information to reproduce or stack dump and full TYPO3 version.

Here, is a report with a very similar exception https://forge.typo3.org/issues/80139. Your exception with U+0000007E implies tilde (~ ) as well.

I can reproduce a problem with links with tilde: Error message: Exception: NAMEPREP: Prohibited input U+0000007E. I am opening up a new issue for that, https://forge.typo3.org/issues/86921 'cause it is not related to cookie alerts and may be the same problem, but I currently don't know.

#3

Updated by Sybille Peters over 2 years ago

  • Related to Bug #86921: Linkvalidator reports exception on links with tilde (~) added
#4

Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or ping me.

Thank you and best regards

Also available in: Atom PDF