Bug #85128

typolinkEnableLinksAcrossDomains builds insecure http:// links even when SSL is enabled for current domain

Added by Helmut Hummel about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-05-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given I have multi domain installation with two domains, both SSL secured.

When TYPO3 generates a link from within one domain to another, http:// is always used as protocol.

Expectation: https:// is used when creating links to the different domain.


Related issues

Is duplicate of TYPO3 Core - Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrlClosed2018-05-29

Actions
#1

Updated by Helmut Hummel about 3 years ago

  • Description updated (diff)
#2

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57101

#3

Updated by Helmut Hummel about 3 years ago

  • Is duplicate of Bug #85111: HTTPS not used for cross-domain links without forceAbsoluteUrl added
#4

Updated by Helmut Hummel about 3 years ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF