Bug #85193

Epic #84044: Admin Panel Rework

AdminPanel Initialization depends on parsed TypoScript

Added by Susanne Moog over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
Start date:
2018-06-09
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since #85104 the admin panel will only initialize if the TypoScript is available, the middleware is however called before the typoscript is fully parsed resulting in inconsistent behaviour depending on the current cache state.

Associated revisions

Revision f2440633 (diff)
Added by Susanne Moog over 1 year ago

[BUGFIX] Remove TypoScript dependency of AdminPanelInitiator

The admin panel initialization is done via middleware before the
TypoScript is fully initialized, therefor it cannot have dependencies
to parsed TypoScript (and it cannot be initialized at a later state
because of cross-dependencies with TSFE).

Before #85104 the checks did not include TypoScript - that state has
been restored and the dependency has been removed.

Resolves: #85193
Releases: master
Change-Id: Ic576b02a68ddc20f52b4b1647b0e38c51e1b7df8
Reviewed-on: https://review.typo3.org/57147
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57147

#2 Updated by Susanne Moog over 1 year ago

  • Assignee set to Susanne Moog
  • Target version set to 9.3

#3 Updated by Susanne Moog over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF