Bug #85229

Invalid condition in suggest receiver page collection

Added by Alexander Stehlik over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2018-06-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

An invalid condition was introduced in getAllSubpagesOfPage() in the SuggestWizardDefaultReceiver in #77049:

$rows = array_column(($rows ?: []), 'uid', 'uid');
if (!count($rows)) {
    $pageIds = array_keys($rows);
    $pages = array_merge($pages, $pageIds);
} else {
    break;
}

The loop quits when there are no results!

Hint for testing

The error is only relevant when a custom recursive PID list is used:

TCEFORM.pages.content_from_pid.suggest.default {
    pidList = 12
    pidDepth = 99
}

Related issues

Related to TYPO3 Core - Task #77049: Doctrine: Migrate ext:backend/Form/Wizard/SuggestWizardDefaultReceiver Closed 2016-07-12

Associated revisions

Revision 52aa454e (diff)
Added by Alexander Stehlik over 2 years ago

[BUGFIX] Fix collection of allowed pages in suggest receiver

When using the pidList and pidDepth TSconfig settings of the
suggest wizard the recursive collection of the allowed
pages does not abort too early any more due to an invalid condition.

Resolves: #85229
Relates: #77049
Releases: master, 8.7
Change-Id: I2c94f5cc64f57be1319f9e76ed05310fbea0db16
Reviewed-on: https://review.typo3.org/57194
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

Revision 255cc86d (diff)
Added by Alexander Stehlik over 2 years ago

[BUGFIX] Fix collection of allowed pages in suggest receiver

When using the pidList and pidDepth TSconfig settings of the
suggest wizard the recursive collection of the allowed
pages does not abort too early any more due to an invalid condition.

Resolves: #85229
Relates: #77049
Releases: master, 8.7
Change-Id: I2c94f5cc64f57be1319f9e76ed05310fbea0db16
Reviewed-on: https://review.typo3.org/57336
Tested-by: TYPO3com <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

History

#1 Updated by Alexander Stehlik over 2 years ago

  • Related to Task #77049: Doctrine: Migrate ext:backend/Form/Wizard/SuggestWizardDefaultReceiver added

#2 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57194

#3 Updated by Alexander Stehlik over 2 years ago

  • Description updated (diff)

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57194

#5 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57194

#6 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57336

#7 Updated by Alexander Stehlik over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF