Bug #85498

Wrong URL for "view" when in workspace with TYPO3 in subdirectory

Added by Rudy Gnodde over 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2018-07-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have TYPO3 installed in a subdirectory (so in domain.com/directory). If I select a workspace and try to view a page using the "View" button from the record of "Show" from the page tree menu the URL is wrong. It adds the subdirectory to the URL twice (so domain.com/directory/directory).

I tested this with a current installation from master in the following way:

- Install TYPO3 in a subdirectory using The official Introduction Package preconfigured distribution
- Activate workspaces extension
- Go to the workspace
- Select "Show" in the page tree menu on a page

#1

Updated by Rudy Gnodde over 3 years ago

This happens because in EXT:workspaces\Classes\Preview\PreviewUriBuilder.php in method buildUriForWorkspaceSplitPreview it returns $viewScript with the directory. In EXT:backend\Classes\Utility\BackendUtility.php at the end of method createPreviewUrl, it prepends $viewDomain, which uses TYPO3_SITE_URL which also includes the directory.

#2

Updated by Benni Mack over 2 years ago

  • Status changed from New to Needs Feedback

Can you recheck this with 9.5.5 as we've fixed the preview linsk back then?

#3

Updated by Rudy Gnodde over 2 years ago

It works correctly in TYPO3 9.5.5, so it seems to be fixed.

#4

Updated by Benni Mack over 2 years ago

  • Status changed from Needs Feedback to Closed

Great. Thanks!

Also available in: Atom PDF