Bug #85535

translate does not show languages to chose from, when a translated item exists

Added by Daxboeck no-lastname-given 12 months ago. Updated 10 months ago.

Status:
New
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Start date:
2018-07-12
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
translate user interface
Complexity:
easy
Is Regression:
Sprint Focus:

Description

We see the following issue when creating translations of an element:

Given Scenario:
- we have 3 languages: default(English), Swiss German and Swiss French.
- we created content in "default" and already have translated all stuff to "Swiss German" and we work on "Swiss French".
- we have 1 Header Element and 3 Text and Media elements in "Default" and translated to "Swiss German".

Now the Editor is working to create "Swiss French" translations.
He takes the "Header" from Swiss German and clicks on "Swiss French[New]" above, changes the content to French and saves it.

Now he wants to get the other 3 Text and Media elements form "Default" and click on the "Translate" button.
to his annoyance, he does not get the choice to take the content from "default".

this behavior of the "translate" button is irritating and not intuitive and in situations like above even annoying.
No matter the case, the "translate" button should always give all potential source languages as a choice.
At least, there should be a system configuration option, to chose the behaviour within a TYPO3 installation.

History

#1 Updated by Susanne Moog 10 months ago

  • Target version changed from 8.7.19 to Candidate for patchlevel

Also available in: Atom PDF