Bug #85561

Class "\Doctrine\Common\Lexer" not found while TYPO3 installation

Added by Salvatore Eckel over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2018-07-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

I was creating a new TYPO3 v9.3 project with Composer.

In the installation wizard in the step where I can create the admin user, I got an error in the network request that says:

... Class "\Doctrine\Common\Lexer" not found while TYPO3 installation ...

After a while of debugging I realized, that there is no class "\Doctrine\Common\Lexer", but this class does exist: "\Doctrine\Common\Lexer\AbstractLexer"

So I changed 1 line of code in this file [[https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/core/Classes/Database/Schema/Parser/Lexer.php#L22]]
and the error was solved:

BEFORE:
class Lexer extends \Doctrine\Common\Lexer

AFTER, this worked:
class Lexer extends \Doctrine\Common\Lexer\AbstractLexer


Can you please check that?
Some months ago, I have installed TYPO3 v9 without such a problem. hhumm..

Salvatore


Related issues

Is duplicate of TYPO3 Core - Bug #85552: Installation of v9 not possible anymore since doctrine/dbal 2.8ClosedAndreas Fernandez2018-07-13

Actions
#1

Updated by Wouter Wolters over 3 years ago

  • Is duplicate of Bug #85552: Installation of v9 not possible anymore since doctrine/dbal 2.8 added
#2

Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Rejected

Thanks for reporting. This issue is known already at #85552 Patch is pending in our review system.

Closing as duplicate ticket.

Also available in: Atom PDF