Bug #85659

Retrieve correct PackageManager in Install Tool

Added by Nicole Cordes almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2018-07-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Using \TYPO3\CMS\Core\Core\Bootstrap::getEarlyInstances to retrieve an instance of PackageManager is the wrong way to go. We need to use GeneralUtility::makeInstance instead.


Related issues

Related to TYPO3 Core - Bug #85634: Core does not recover if PackageStates.php is corrupted/removedClosed2018-07-24

Actions
#1

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57692

#2

Updated by Gerrit Code Review almost 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57692

#3

Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Markus Klein almost 3 years ago

  • Related to Bug #85634: Core does not recover if PackageStates.php is corrupted/removed added
#5

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF