Bug #85814

Correctly initialize environment for DataHandler in tests

Added by Oliver Hader 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Tests
Target version:
-
Start date:
2018-08-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Task #85813: Add frontend functional tests for site handling Closed 2018-08-10

Associated revisions

Revision b13ccf1f (diff)
Added by Oliver Hader 11 months ago

[TASK] Correctly initialize environment for DataHandler in tests

Since importing data scenarios in tests relies on DataHandler, it is
required to correctly initialize $GLOBALS['LANG'] as well. Since not
all tests were failing, this probably points out side effects during
test execution in terms of reusing globals settings of other tests.

Besides that, a misbehavior in typo3/testing-framework lead to the
situation that not all entities have been created - which would have
triggered DataHandler log entries that rely on previously mentioned
$GLOBALS['LANG'] instance.

Resolves: #85814
Releases: master
Change-Id: I4e2745cfeed6e2576f7ae23dd4d4ea4b49572a3f
Reviewed-on: https://review.typo3.org/57869
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Oliver Hader 11 months ago

  • Related to Task #85813: Add frontend functional tests for site handling added

#2 Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57869

#3 Updated by Gerrit Code Review 11 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57869

#4 Updated by Oliver Hader 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 10 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF