Bug #86074

Epic #84726: Initiative: URL Routing Integration / Site Handling

Epic #84728: Introduce speaking URLs for pages

Epic #84729: Implement "slug" handling for pages and other records

Properly create slug if adding new pages via FormEngine

Added by Christian Kuhn over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-09-01
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Associated revisions

Revision dfe61898 (diff)
Added by Christian Kuhn over 1 year ago

[BUGFIX] Properly create slug if adding new pages via FormEngine

Adding a page relative to another page (vanillaUid is negative then),
currently creates a slug as if the page in inside the related page.
This is because the vanillaUid is given to the JS and later fed to
the ajax slug creator.
Using 'effectivePid' instead which is the parent page uid if a
new page is added, or the uid of the page recod itself if the
page is edited, solves the issue.

Resolves: #86074
Releases: master
Change-Id: Ia3f89f615699d4e7be6bc1762bc95e17cc1939dc
Reviewed-on: https://review.typo3.org/58117
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Tested-by: TYPO3com <>
Reviewed-by: Kevin Appelt <>
Tested-by: Kevin Appelt <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58117

#2 Updated by Christian Kuhn over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF