Bug #86091

Empty documentroot causes errors in unit tests when used as needle in strpos on Windows

Added by Jigal van Hemert over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Tests
Target version:
Start date:
2018-09-02
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

\TYPO3\CMS\Core\Tests\Unit\Cache\Backend\FileBackendTest::setCacheDirectoryAllowsAbsolutePathWithoutTrailingSlash() and similar tests set the cache directory of the FileBackend. In that process an empty documentroot causes a warning in strpos() where it's used as 'needle'.

#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58132

#2

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58132

#3

Updated by Jigal van Hemert over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF