Bug #86161

data.t3d does not get imported when installing a site package

Added by Philipp Faber about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2018-09-06
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When installing a new site package in TYPO 9.4.0 with a data.t3d or data.xml in the Initialisation directory, data does not get imported. When setting it up with helhum's console, an error occurs and when doing it by hand via the Extension Manager, the extension is installed, but the data file is not being imported. I tried it multiple times with new databases. AFAIK this still worked in 9.3.0. I also created a new @data.t3d file in v9.4.0 for testing and used that instead, but same error. This is what the console says:

[ TYPO3\CMS\Core\Error\Exception ]

Warning: reset() expects parameter 1 to be array, null given in 
/mnt/e/xampp/htdocs/tests/test.de/public/typo3/sysext/impexp/Classes/Utility/ImportExportUtility.php line 58

Associated revisions

Revision 56d60665 (diff)
Added by Susanne Moog 12 months ago

[BUGFIX] Add user authentication to activate extension command

As extensions might contain data to import the activate extension
command needs to initialize the user authentication so the data
handler may import data.

The backend user authentication initialization has been added to
the activate extension command.

Resolves: #86161
Releases: master
Change-Id: Id25c45bdfc8ac1cb930c9ed6adb49c39c17d7952
Reviewed-on: https://review.typo3.org/58536
Reviewed-by: Frank Naegler <>
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Susanne Moog about 1 year ago

  • Target version changed from next-patchlevel to 9 LTS

#2 Updated by Susanne Moog about 1 year ago

  • Category set to Extension Manager

#3 Updated by Susanne Moog 12 months ago

  • Status changed from New to Needs Feedback

There was a recent bugfix for import/export that should fix the import with the TYPO3 backend (that no files were written). Can you verify that it's working on latest master please?

#4 Updated by Susanne Moog 12 months ago

  • Status changed from Needs Feedback to Accepted

To reproduce on current master:

- install via composer
- composer require typo3/cms-introduction
- ./vendor/bin/typo3 extension:activate bootstrap_package
- ./vendor/bin/typo3 extension:activate introduction

#5 Updated by Gerrit Code Review 12 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58536

#6 Updated by Susanne Moog 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF